PEBA browser and PDF viewer suppport

PEBA web applications support Internet Explorer 11, Chrome, Edge, Firefox and Safari. Each time a new browser version is released, we begin supporting that version and stop supporting the third most recent version.

Many modern browsers include a built in PDF viewer. PEBA supports the built in PDF viewers in Chrome, Edge, Firefox and Safari, and supports the latest version of Adobe Acrobat Reader.

Our goal is to provide accurate content through secure, accessible, and intuitive websites. To get the best use of our websites, we recommend that you use updated software. Also, cookies and JavaScript must be enabled.

Web applications are created using an assortment of software tools which ultimately run on a variety of web browsers. We use a progressive tool selection to offer the safest, most functional and visually pleasing application we can. A safe browsing experience requires the use of a modern browser, fully patched operating system software, and a recent PDF viewer. For that reason, older web browsers and PDF viewers cannot be supported nor do we recommend the continued use of them.